Kingfisher patrol

On Friday, I ducked out of work early to go kayaking because I’d been kept late for various emergencies on previous days. I have been a little worried about the “NO TRESPASSING” and “AUTHORIZED VEHICLES ONLY” signs that have appeared at my put-in at Browncroft Avenue, so I was planning to go down to BayCreek and put in there, but the wind was blowing so strongly that I decided I’d risk the parking ticket and put-in on the more sheltered part of the creek.
Continue reading “Kingfisher patrol”


Hey, I’ve got a weird idea: When a beta customer, who is using build 30, starts complaining about the same problem we’ve spend the last 15 builds trying to fix, maybe instead of pulling several of us off our work to look to see if we can manually enter stuff into their database to kluge it up to get them going again, you should update them to build 45? Just a suggestion.

Some upgrades are easier that others

I just upgraded my blog software from 2.1 to 2.2.1. I’ve been wanting to do that for a while, but I wanted some free time. Once again, I ignored the bit in the instructions where it says to deactivate all the plugins first and then reactivate them afterwards, and once again the upgrade worked perfectly. Ok, I had to re-activate the options to get the category and archive widgets as dropdowns, but that was simple.

Can I just digress for a moment?

I just want to say that I HATE HATE HATE rpm and it’s fucking broken dependency checking?

At work, we use apt-rpm so that we have a hope in hell of dependencies being satisfied when we install stuff. Our previous build of our software uses the RHEL 4.3 default version of dnotify, 0.17.2-1, but our current build needs a version we got from somewhere else, which is version 0.18.0-1. So I dutifully changed the

Requires: dnotify


Requires: dnotify >= 0.18

But it doesn’t matter whether I install it using “rpm -Uvh foo” or “apt-get install foo”, it happily installs the latest version of our stuff without complaining about unmet dependencies or attempting to upgrade dnotify. WTF? I tried with “0.18”, “0.18.0” and “0.18.0-1”, all with no effect.

I did verify with “rpm -q -provides” and “rpm -q -requires” that the version numbers internal to the rpms in question agree with the file name versions and the dependencies made it into the rpm. So it’s not a case of a file “dnotify-0.18.0-1.rpm” that internally thinks it’s dnotify version 0.01 or something stupid like that. It’s just fucking rpm being fucking brain dead.