I just want to say that I HATE HATE HATE rpm and it’s fucking broken dependency checking?
At work, we use apt-rpm so that we have a hope in hell of dependencies being satisfied when we install stuff. Our previous build of our software uses the RHEL 4.3 default version of dnotify, 0.17.2-1, but our current build needs a version we got from somewhere else, which is version 0.18.0-1. So I dutifully changed the
Requires: dnotify >= 0.18
But it doesn’t matter whether I install it using “rpm -Uvh foo” or “apt-get install foo”, it happily installs the latest version of our stuff without complaining about unmet dependencies or attempting to upgrade dnotify. WTF? I tried with “0.18”, “0.18.0” and “0.18.0-1”, all with no effect.
I did verify with “rpm -q -provides” and “rpm -q -requires” that the version numbers internal to the rpms in question agree with the file name versions and the dependencies made it into the rpm. So it’s not a case of a file “dnotify-0.18.0-1.rpm” that internally thinks it’s dnotify version 0.01 or something stupid like that. It’s just fucking rpm being fucking brain dead.